سكربتات مهمة جدا لكل مستخدمي ميكروتك



    سكربت مهم جدا لفص pppoe النشطين
    # Print local time for LOG record purposes / tracking
    :local CurrentTime [/system clock get time];
    :log warning "Script Start to Disconnect all active PPPoE Users for RM Data record purposes at $CurrentTime. . ."
    # Disconnect users using find
    /ppp active remove [find service="pppoe"] :log warning "Users disconnection script completed at $CurrentTime. . ."

    تعطيل مستخدمي هوت سبوت الذين ليس لديهم  اشعارات دفع

    # Script source: http://forum.mikrotik.com/viewtopic.php?f=9&t=82129
    # To block HOTSPOT users who donot have comments "PAID" in there comment box
    # Syed Jahanzaib / aacable@hotamil.com / http://aacable.wordpress.com
    /ip hotspot user
    :foreach i in=[find] do={
    :local username [get $i name] :if ([get $i comment]~"paid") do={
    } else={
    :log warning "$username..."
    /ip hotspot user disable $username
    }
    }
    سكربت للحد من الاختراقات

    {
    :delay 500ms
    :local x $user;
    :local y [/ip hotspot active get [find user=$x] address];
    :local f [/ip hotspot host get [find to-address=$y] address];
    :local c [/ip hotspot active get [find user=$x] login-by];
    :local b "http-pap";
    :local k "http-chap";


    :local n [/ip dhcp-server lease get [find active-address=$f] host-name];
    if (c = b || c = k || c = v) do={
    :log warning "Hostname Shield - $x Login is valid"
    /ip firewall address-list add list=$n } else={
    if ( [ :len [ ip firewall address-list find where list="$n" ] ] > 0 ) do={ :log warning "Hostname Shield - Login is valid" } else={ip hotspot active remove [find user=$x]
    :log warning "Hostname Shield -login not allowed "
    }}}
    :local v "cookie";
     



     أحمد صوان - Ahmed Sawan
    @مرسلة بواسطة
    كاتب ومحرر اخبار اعمل في موقع وي كايرو .

    إرسال تعليق